re = /(?:"(\w+)"?(?=\s*,))|\W*,\W*(\d+)|\((\d)|"(.*)?(\W)"\)/m
str = 'function(1)
function(2, 3)
function("ABOBORA","MORANGO","BOLACHA" , 44 ,55)
function("ABOBORA","MORANGO","BOLACHA" "66")
function("ABOBORA","MORANGO","BOLACHA", "77")
function("ABOBORA","MORANGO","BOLACHA" . "88)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end