const regex = /(?:"(\w+)"?(?=\s*,))|\W*,\W*(\d+)|\((\d)|"(.*)?(\W)"\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"(\\w+)"?(?=\\s*,))|\\W*,\\W*(\\d+)|\\((\\d)|"(.*)?(\\W)"\\)', 'gm')
const str = `function(1)
function(2, 3)
function("ABOBORA","MORANGO","BOLACHA" , 44 ,55)
function("ABOBORA","MORANGO","BOLACHA" "66")
function("ABOBORA","MORANGO","BOLACHA", "77")
function("ABOBORA","MORANGO","BOLACHA" . "88)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}