using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""(\w+)""?(?=\s*,))|\W*,\W*(\d+)|\((\d)|""(.*)?(\W)""\)";
string input = @"function(1)
function(2, 3)
function(""ABOBORA"",""MORANGO"",""BOLACHA"" , 44 ,55)
function(""ABOBORA"",""MORANGO"",""BOLACHA"" ""66"")
function(""ABOBORA"",""MORANGO"",""BOLACHA"", ""77"")
function(""ABOBORA"",""MORANGO"",""BOLACHA"" . ""88)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}