use strict;
my $str = 'function(1)
function(2, 3)
function("ABOBORA","MORANGO","BOLACHA" , 44 ,55)
function("ABOBORA","MORANGO","BOLACHA" "66")
function("ABOBORA","MORANGO","BOLACHA", "77")
function("ABOBORA","MORANGO","BOLACHA" . "88)';
my $regex = qr/(?:"(\w+)"?(?=\s*,))|\W*,\W*(\d+)|\((\d)|"(.*)?(\W)"\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}