#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:"(\w+)"?(?=\s*,))|\W*,\W*(\d+)|\((\d)|"(.*)?(\W)"\)"
Local $sString = "function(1)" & @CRLF & _
"function(2, 3)" & @CRLF & _
"function("ABOBORA","MORANGO","BOLACHA" , 44 ,55)" & @CRLF & _
"function("ABOBORA","MORANGO","BOLACHA" "66")" & @CRLF & _
"function("ABOBORA","MORANGO","BOLACHA", "77")" & @CRLF & _
"function("ABOBORA","MORANGO","BOLACHA" . "88)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")