$re = '/(?:"(\w+)"?(?=\s*,))|\W*,\W*(\d+)|\((\d)|"(.*)?(\W)"\)/m';
$str = 'function(1)
function(2, 3)
function("ABOBORA","MORANGO","BOLACHA" , 44 ,55)
function("ABOBORA","MORANGO","BOLACHA" "66")
function("ABOBORA","MORANGO","BOLACHA", "77")
function("ABOBORA","MORANGO","BOLACHA" . "88)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);