re = /\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)/m
str = '(2000)
(2000, 435)
(2000 435)
(2000, 435-67)
(2000 435-67)
(2000 435-67, 71)
(2000, 435-67, 71)
(2000, 435-67, 71-4)https://regex101.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end