#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)"
Local $sString = "(2000)" & @CRLF & _
"(2000, 435)" & @CRLF & _
"(2000 435)" & @CRLF & _
"(2000, 435-67)" & @CRLF & _
"(2000 435-67)" & @CRLF & _
"(2000 435-67, 71)" & @CRLF & _
"(2000, 435-67, 71)" & @CRLF & _
"(2000, 435-67, 71-4)https://regex101.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")