package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)`)
var str = `(2000)
(2000, 435)
(2000 435)
(2000, 435-67)
(2000 435-67)
(2000 435-67, 71)
(2000, 435-67, 71)
(2000, 435-67, 71-4)https://regex101.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}