$re = '/\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)/m';
$str = '(2000)
(2000, 435)
(2000 435)
(2000, 435-67)
(2000 435-67)
(2000 435-67, 71)
(2000, 435-67, 71)
(2000, 435-67, 71-4)https://regex101.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);