using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(?(?:\d{4})(?:(?:,? .?\d+)?(?:[–|\-]\d+)?)+\)";
string input = @"(2000)
(2000, 435)
(2000 435)
(2000, 435-67)
(2000 435-67)
(2000 435-67, 71)
(2000, 435-67, 71)
(2000, 435-67, 71-4)https://regex101.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}