import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?(?:\\d{4})(?:(?:,? .?\\d+)?(?:[–|\\-]\\d+)?)+\\)";
final String string = "(2000)\n"
+ "(2000, 435)\n"
+ "(2000 435)\n"
+ "(2000, 435-67)\n"
+ "(2000 435-67)\n"
+ "(2000 435-67, 71)\n"
+ "(2000, 435-67, 71)\n"
+ "(2000, 435-67, 71-4)https://regex101.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}