import Foundation
let pattern = #"(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
MP1 Chicago
MP7 Chicago
MP1. Chicago
MP7. Chicago
MP.1 Chicago
MP.7 Chicago
MP1.1 Chicago
MP7.7 Chicago
MP1Chicago
MP7Chicago
MP1.Chicago
MP7.Chicago
MP.1Chicago
MP.7Chicago
MP1.1Chicago
MP7.7Chicago
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)