#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})"
Local $sString = "MP1 Chicago" & @CRLF & _
"MP7 Chicago" & @CRLF & _
"MP1. Chicago" & @CRLF & _
"MP7. Chicago" & @CRLF & _
"MP.1 Chicago" & @CRLF & _
"MP.7 Chicago" & @CRLF & _
"MP1.1 Chicago" & @CRLF & _
"MP7.7 Chicago" & @CRLF & _
"MP1Chicago" & @CRLF & _
"MP7Chicago" & @CRLF & _
"MP1.Chicago" & @CRLF & _
"MP7.Chicago" & @CRLF & _
"MP.1Chicago" & @CRLF & _
"MP.7Chicago" & @CRLF & _
"MP1.1Chicago" & @CRLF & _
"MP7.7Chicago"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")