# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})"
test_str = ("MP1 Chicago\n"
"MP7 Chicago\n"
"MP1. Chicago\n"
"MP7. Chicago\n"
"MP.1 Chicago\n"
"MP.7 Chicago\n"
"MP1.1 Chicago\n"
"MP7.7 Chicago\n"
"MP1Chicago\n"
"MP7Chicago\n"
"MP1.Chicago\n"
"MP7.Chicago\n"
"MP.1Chicago\n"
"MP.7Chicago\n"
"MP1.1Chicago\n"
"MP7.7Chicago")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.