use strict;
my $str = 'MP1 Chicago
MP7 Chicago
MP1. Chicago
MP7. Chicago
MP.1 Chicago
MP.7 Chicago
MP1.1 Chicago
MP7.7 Chicago
MP1Chicago
MP7Chicago
MP1.Chicago
MP7.Chicago
MP.1Chicago
MP.7Chicago
MP1.1Chicago
MP7.7Chicago';
my $regex = qr/(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}