using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})";
string input = @"MP1 Chicago
MP7 Chicago
MP1. Chicago
MP7. Chicago
MP.1 Chicago
MP.7 Chicago
MP1.1 Chicago
MP7.7 Chicago
MP1Chicago
MP7Chicago
MP1.Chicago
MP7.Chicago
MP.1Chicago
MP.7Chicago
MP1.1Chicago
MP7.7Chicago";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}