const regex = /(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:MP)([0-9]{1,}|[0-9]{1,}\\.|\\.[0-9]{1,}|[0-9]{1,}\\.[0-9]{1,}|)(?:\\s{1,})(.{1,})', 'g')
const str = `MP1 Chicago
MP7 Chicago
MP1. Chicago
MP7. Chicago
MP.1 Chicago
MP.7 Chicago
MP1.1 Chicago
MP7.7 Chicago
MP1Chicago
MP7Chicago
MP1.Chicago
MP7.Chicago
MP.1Chicago
MP.7Chicago
MP1.1Chicago
MP7.7Chicago`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}