re = /(discord\.com\/invite\/|discordapp\.com\/invite\/|discord\.gg\/|\.gg\/)([a-zA-Z0-9]+)/m
str = '0. discord.com/invite/InviteCode
1. discordapp.com/invite/InviteCode
2. discord.gg/InviteCode
3. .gg/InviteCode'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end