$re = '/(discord\.com\/invite\/|discordapp\.com\/invite\/|discord\.gg\/|\.gg\/)([a-zA-Z0-9]+)/m';
$str = '0. discord.com/invite/InviteCode
1. discordapp.com/invite/InviteCode
2. discord.gg/InviteCode
3. .gg/InviteCode';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);