using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(discord\.com\/invite\/|discordapp\.com\/invite\/|discord\.gg\/|\.gg\/)([a-zA-Z0-9]+)";
string input = @"0. discord.com/invite/InviteCode
1. discordapp.com/invite/InviteCode
2. discord.gg/InviteCode
3. .gg/InviteCode";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}