import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(discord\\.com\\/invite\\/|discordapp\\.com\\/invite\\/|discord\\.gg\\/|\\.gg\\/)([a-zA-Z0-9]+)";
final String string = "0. discord.com/invite/InviteCode\n"
+ "1. discordapp.com/invite/InviteCode\n"
+ "2. discord.gg/InviteCode\n"
+ "3. .gg/InviteCode";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}