const regex = /(discord\.com\/invite\/|discordapp\.com\/invite\/|discord\.gg\/|\.gg\/)([a-zA-Z0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(discord\\.com\\\/invite\\\/|discordapp\\.com\\\/invite\\\/|discord\\.gg\\\/|\\.gg\\\/)([a-zA-Z0-9]+)', 'gm')
const str = `0. discord.com/invite/InviteCode
1. discordapp.com/invite/InviteCode
2. discord.gg/InviteCode
3. .gg/InviteCode`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}