#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(discord\.com\/invite\/|discordapp\.com\/invite\/|discord\.gg\/|\.gg\/)([a-zA-Z0-9]+)"
Local $sString = "0. discord.com/invite/InviteCode" & @CRLF & _
"1. discordapp.com/invite/InviteCode" & @CRLF & _
"2. discord.gg/InviteCode" & @CRLF & _
"3. .gg/InviteCode"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")