// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)").unwrap();
let string = "101.23052.0004";
let substitution = "101.23052.0004";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}