# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)/101.23052.0004/m;t' <<< "101.23052.0004"