import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([6]\\.[1]\\.([3-9]$|[1-9]\\d{1,}))|([6]\\.([2-9]|[1-9]\\d{1,})\\.\\d*)|(([7-9]|[1-9]\\d{1,})\\.\\d*\\.\\d*)";
final String string = "101.23052.0004";
final String subst = "101.23052.0004";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}