const regex = /([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([6]\\.[1]\\.([3-9]$|[1-9]\\d{1,}))|([6]\\.([2-9]|[1-9]\\d{1,})\\.\\d*)|(([7-9]|[1-9]\\d{1,})\\.\\d*\\.\\d*)', 'm')
const str = `101.23052.0004`;
const subst = `101.23052.0004`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);