package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)`)
var str = []byte(`101.23052.0004`)
var substitution = []byte("101.23052.0004")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}