using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([6]\.[1]\.([3-9]$|[1-9]\d{1,}))|([6]\.([2-9]|[1-9]\d{1,})\.\d*)|(([7-9]|[1-9]\d{1,})\.\d*\.\d*)";
string substitution = @"101.23052.0004";
string input = @"101.23052.0004";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}