import Foundation
let pattern = #"^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234567
12345678
01212345678
012-12345678
1234-1234567
1234-12345678
012/1234567
012/12345678
1234/1234567
1234/12345678
13585881145
012-1345678-1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)