package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$`)
var str = `1234567
12345678
01212345678
012-12345678
1234-1234567
1234-12345678
012/1234567
012/12345678
1234/1234567
1234/12345678
13585881145
012-1345678-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}