#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$"
Local $sString = "1234567" & @CRLF & _
"12345678" & @CRLF & _
"01212345678" & @CRLF & _
"012-12345678" & @CRLF & _
"1234-1234567" & @CRLF & _
"1234-12345678" & @CRLF & _
"012/1234567" & @CRLF & _
"012/12345678" & @CRLF & _
"1234/1234567" & @CRLF & _
"1234/12345678" & @CRLF & _
"13585881145" & @CRLF & _
"012-1345678-1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")