use strict;
my $str = '1234567
12345678
01212345678
012-12345678
1234-1234567
1234-12345678
012/1234567
012/12345678
1234/1234567
1234/12345678
13585881145
012-1345678-1234';
my $regex = qr/^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}