$re = '/^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$/m';
$str = '1234567
12345678
01212345678
012-12345678
1234-1234567
1234-12345678
012/1234567
012/12345678
1234/1234567
1234/12345678
13585881145
012-1345678-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);