# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^1\d{10}$|^(\d{3,4}[-\/]?)?\d{7,8}([-\/]\d{2,4})?$"
test_str = ("1234567\n"
"12345678\n"
"01212345678\n"
"012-12345678\n"
"1234-1234567\n"
"1234-12345678\n"
"012/1234567\n"
"012/12345678\n"
"1234/1234567\n"
"1234/12345678\n"
"13585881145\n"
"012-1345678-1234")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.