re = /Else(?!If)[ \t]*;?/m
str = 'Else ;
Else
Else ;//------------------------------------------------------
//ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line)
//ElseIf bc=2
//Else
Else ;//ну вообще большой взрыв
'
subst = '\\} else \\{ '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result