const regex = /Else(?!If)[ \t]*;?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Else(?!If)[ \\t]*;?', 'gm')
const str = `Else ;
Else
Else ;//------------------------------------------------------
//ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line)
//ElseIf bc=2
//Else
Else ;//ну вообще большой взрыв
`;
const subst = `\} else \{ `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);