using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Else(?!If)[ \t]*;?";
string substitution = @"\} else \{ ";
string input = @"Else ;
Else
Else ;//------------------------------------------------------
//ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line)
//ElseIf bc=2
//Else
Else ;//ну вообще большой взрыв
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}