# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Else(?!If)[ \t]*;?"
test_str = ("Else ;\n"
" Else\n"
" Else ;//------------------------------------------------------ \n"
" //ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line) \n"
" //ElseIf bc=2\n"
" //Else\n"
" Else ;//ну вообще большой взрыв\n")
subst = "\\} else \\{ "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.