import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Else(?!If)[ \\t]*;?";
final String string = "Else ;\n"
+ " Else\n"
+ " Else ;//------------------------------------------------------ \n"
+ " //ElseIf TPlayer(ob) && TPlayer(ob).ProcessLine(Line) \n"
+ " //ElseIf bc=2\n"
+ " //Else\n"
+ " Else ;//ну вообще большой взрыв\n";
final String subst = "\\} else \\{ ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}