import Foundation
let pattern = #"\+\d{2,3}[\d -]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Markus Tschopp | Mercurius Trading Ltd.
Rote Trotte 10
Postfach 1720
6340 Baar | Switzerland
Phone: +41 41 7630650
For EU customers: +49 172 68 51 259
Fax: +41 41 7630651
Skype: www.watches.de
+381 63 1070756
+41 41-76-3065-0 Marko
+41417630650
Questions? info@watches.de
Business hours:
Monday - Friday 10 am - 6 pm
By email 24 hours
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)