const regex = /\+\d{2,3}[\d -]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+\\d{2,3}[\\d -]+', 'g')
const str = `Markus Tschopp | Mercurius Trading Ltd.
Rote Trotte 10
Postfach 1720
6340 Baar | Switzerland
Phone: +41 41 7630650
For EU customers: +49 172 68 51 259
Fax: +41 41 7630651
Skype: www.watches.de
+381 63 1070756
+41 41-76-3065-0 Marko
+41417630650
Questions? info@watches.de
Business hours:
Monday - Friday 10 am - 6 pm
By email 24 hours`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}