re = /\+\d{2,3}[\d -]+/
str = 'Markus Tschopp | Mercurius Trading Ltd.
Rote Trotte 10
Postfach 1720
6340 Baar | Switzerland
Phone: +41 41 7630650
For EU customers: +49 172 68 51 259
Fax: +41 41 7630651
Skype: www.watches.de
+381 63 1070756
+41 41-76-3065-0 Marko
+41417630650
Questions? info@watches.de
Business hours:
Monday - Friday 10 am - 6 pm
By email 24 hours'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end