#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\+\d{2,3}[\d -]+"
Local $sString = "Markus Tschopp | Mercurius Trading Ltd." & @CRLF & _
"Rote Trotte 10" & @CRLF & _
"Postfach 1720" & @CRLF & _
"6340 Baar | Switzerland" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Phone: +41 41 7630650" & @CRLF & _
"For EU customers: +49 172 68 51 259" & @CRLF & _
"Fax: +41 41 7630651" & @CRLF & _
"Skype: www.watches.de" & @CRLF & _
"+381 63 1070756" & @CRLF & _
"+41 41-76-3065-0 Marko" & @CRLF & _
"+41417630650" & @CRLF & _
"" & @CRLF & _
"Questions? info@watches.de" & @CRLF & _
"" & @CRLF & _
"Business hours:" & @CRLF & _
"Monday - Friday 10 am - 6 pm" & @CRLF & _
"By email 24 hours"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")