import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+\\d{2,3}[\\d -]+";
final String string = "Markus Tschopp | Mercurius Trading Ltd.\n"
+ "Rote Trotte 10\n"
+ "Postfach 1720\n"
+ "6340 Baar | Switzerland\n\n"
+ " \n"
+ "Phone: +41 41 7630650\n"
+ "For EU customers: +49 172 68 51 259\n"
+ "Fax: +41 41 7630651\n"
+ "Skype: www.watches.de\n"
+ "+381 63 1070756\n"
+ "+41 41-76-3065-0 Marko\n"
+ "+41417630650\n\n"
+ "Questions? info@watches.de\n\n"
+ "Business hours:\n"
+ "Monday - Friday 10 am - 6 pm\n"
+ "By email 24 hours";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}