# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\+\d{2,3}[\d -]+"
test_str = ("Markus Tschopp | Mercurius Trading Ltd.\n"
"Rote Trotte 10\n"
"Postfach 1720\n"
"6340 Baar | Switzerland\n\n"
" \n"
"Phone: +41 41 7630650\n"
"For EU customers: +49 172 68 51 259\n"
"Fax: +41 41 7630651\n"
"Skype: www.watches.de\n"
"+381 63 1070756\n"
"+41 41-76-3065-0 Marko\n"
"+41417630650\n\n"
"Questions? info@watches.de\n\n"
"Business hours:\n"
"Monday - Friday 10 am - 6 pm\n"
"By email 24 hours")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.