$re = '/(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$/im';
$str = 'file:///Users/john.smith/Projects/joehall-logo-256x256.png
/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip
/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
../../assets/android-chrome-512x512.png
./android-chrome-512x512.png
android-chrome-512x512.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);