#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$"
Local $sString = "file:///Users/john.smith/Projects/joehall-logo-256x256.png" & @CRLF & _
"/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip" & @CRLF & _
"/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png" & @CRLF & _
"~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png" & @CRLF & _
"../../assets/android-chrome-512x512.png" & @CRLF & _
"./android-chrome-512x512.png" & @CRLF & _
"android-chrome-512x512.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")