const regex = /(?=~\/|\.\/|\..\/|\/|file:\/\/\/|\w)[\w\-\._\(\)\[\] ]+$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=~\\\/|\\.\\\/|\\..\\\/|\\\/|file:\\\/\\\/\\\/|\\w)[\\w\\-\\._\\(\\)\\[\\] ]+$', 'gim')
const str = `file:///Users/john.smith/Projects/joehall-logo-256x256.png
/Users/john.smith/Downloads/favicon_package_v0.16 (2).zip
/Users/john.smith/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
~/Downloads/favicon_package_v0.16 (2)/android-chrome-512x512.png
../../assets/android-chrome-512x512.png
./android-chrome-512x512.png
android-chrome-512x512.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}